最近公司网站进入数据库后总是提示错误:Warning in ./libraries/plugin_interface.lib....,可能是PHP与phpmyadmin版本匹配出了问题。

phpmyadmin与PHP匹配说明:
如果只有PHP5.2,请安装 phpmyadmin4.1;
如果只有PHP5.5及以下版本,请安装phpmyadmin4.4;
如果只有PHP7.x,请安装phpmyadmin4.7/4.8/4.9版本。

首先排查下phpmyadmin对应的php版本,以防之前更新过php或者安装多个版本php,但phpmyadmin没有同步切换。

宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

如果这里没有问题,就需要根据php版本安装对应的phpmyadmin。

公司网站用的是php7.4+phpmyadmin4.4版本,所以出现了这个错误,只需升级phpmyadmin就行了。

使用宝塔升级面板phpmyadmin步骤如下:
一、卸载旧版本
到后台软件管理中,卸载phpmyadmin4.4(建议提前备份下数据库)。

宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

二、安装新版本

宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

评论

用户名:
密码:
匿名发表
验证码:
共有条评论